Bug with rights

maybe this what i plain descrbed in this case solves NET-391 but

When i tried limit in some object type password field for only admins (default group in datagerry)

and saved this configure.
Created some object in this object type and completed password field.
I logged from private mode for user who have only rights for view like this:

Opened this object (click on “eye”)
i saw

when i clicked on “eye” in password field whether in the summary or in the section preview i saw password:

So if it doesn’t work i disable limit password field for group admin and tried limit object type for only admins in this place:
and unfortunately result was the same.

a separate matter is that when i create object type and this password field and when i tried limit for user i don’t see any user to choose. check box for user was blank.

This still don’t work in version 1.2.2

Hi @marcinw,

thanks for reporting this. Unfortunately, the functionality to limit object types or fields to specific users is not implemented yet. We prepared the frontend for that functionality (that is why you see all these options), but in the backend the implementation was not done.

At the moment, we plan the roadmap for version 1.4 (November 2020) and I’m prioritizing several feature requests. Can you give me a short feedback, how important such a feature is for your use case?

Hi @mbatz,
it’s not that important. For now, I can cope with using group management, but in the future it would be a good solution, because sometimes it is worth making, for example, that the password field is seen by only a few people, or that certain fields in the object are filled by an appropriate group of people, and other fields - by another. In my head I have such cases that could handle this situation.
It would be worthwhile to see such functionality in the future, but it is not very urgent, and there are more urgent fixes to be done or functionality.
That’s my opinion