Not able to import objects after upgrade to 2.1.0

After the upgrade to 2.1.0 I am not able to import the objects anymore. It hangs on the type mapping and I could not select the type and continue.

Hi @jmatys ,
can you give us more info about the issue ?

Which errors are displayed in your console ?

Which data do you want to import ? Can you provide us a sample so we can test it ?

BR Adnan

Hi, I attached the screenshot what I could see. I am trying to import csv (but I get the same result for json). I did not find any errors, it just hangs with the fox over the screen when reaching the type selection. I get the same result when I upgrade with existing data or if I create the database from scratch. I am able to import the types without any issue, the import does not work only for objects. Could be something in the type definition, maybe some parameter missing in the type.

Hi @jmatys ,
can you paste us here an example type and and example object so we can check it with your data what is going wrong?

BR Adnan

04_02_2024_08_07_44.txt (680 Bytes)
04_02_2024_08_07_29.txt (1.1 KB)

This is one type in json and all objects in csv.

HI @jmatys ,

we could identify some issues with the importer thanks to your contribution.

It will be fixed in the next release.

BR Adnan

Any idea when the next release is foreseen ?

Hi @acpfn,
the next release is currently planned for the end of the next month.

BR Adnan