Bug - Incomprehensible application behavior

Hello @mbatz,
Today I encountered a strange situation in the operation of the application.
I have 2 instances of applications on different servers, the situation occurred on both instances, although it showed differently.
Both instances went from 17/06/2020 and I will add that nothing has been put off in the application logs, either by warnings or errors.

Namely:
1 instance - the application does not go to the tabs:
Categories, Import Type, Export Type, Import Objects, Export Objects, System Information, Authentication, Database Properties, Rights,

2 instance - after the above mentioned also Exportd Job Logs, Users, Groups, Profile

When I clicked on these tabs in the application nothing appeared in the logs, as if the application stopped working
However, when I clicked on the Types tab or walked on objects, it worked
I also tried to add a rigid context, e.g. /framework/category, and this also did not help, after reloading the page returned to the empty and basic link ip_address: 4000 in both instances
image
I tried on chrome , and firefox and results was the same

After restart everything (mongod, rabbitmq and datagerry) on one instance the application started working again correctly on this instance

Hi @marcinw,

can you reproduce that behavior or was that a single case? As I can see with port 4000 in the screenshot, do you access the DATAGERRY webserver directly? We recommend running the application behind an Nginx proxy server for performance reasons.

Hi,
So far, this has only happened once.
Yes one instance work behind Nginx and second work without Nginx and it happened on both instances
This ip_address:4000 i wrote because i can’t show you my addresses which i use.
I can’t reproduce this situation. Maybe if i don’t restart application during 14 days maybe then we could reproduce that behavior or maybe someone else could reproduce that behavior Datagerry or something like that happened to him?

Hi,

just let me know when this error will appear again. I haven’ t seen this in one of our setups yet, but if we see that error again, we need to pay attention on that.

Hi,
Ofcourse i’ll let you know when it happened.